Error:During launch of CoreConfig! ReturnCode:1

Jan 12, 2010 at 5:29 AM

Hi,

I tried to install on 3 individual Core servers, and got an error on all three. It may be something I did wrong during the extract/install. Here's the error:

Error:During launch of CoreConfig! ReturnCode:1 Please copy source to local drive and try again.

Here's what I did to set it up:

I downloaded the cab install

I copied the cab to the C: drive of the core server, then ran 'expand CoreConfig.cab -f:* .' to extract it into the current directory. (I could see the extracted files afterwards)

I then ran start_coreconfig.wsf

It went through the process of installing the netfx-servercore feature, then it said Powershell is already installed. But then it throws the error.
Any suggestions appreciated.

 

Coordinator
Jan 19, 2010 at 1:11 PM

Hi jaykay81

Can you post the directory path here for me to review, as we found a bug if you have a <space> in the directory path. Jaykay can you do us a favour and reboot your host and running the application again to see if this relates to powershell installation.

will wait for your reply

Regards

CoreConfigTeam

Jan 19, 2010 at 11:38 PM

I removed the space from the directory name, it worked. Thanks guys-great tool

 

Jun 27, 2010 at 1:04 AM

I found the solution in the code.

In the Start_CoreConfig.wsf file - change the following line:

iRetCode = WshShell.Run ("C:\Windows\system32\WindowsPowerShell\v1.0\powershell.exe " & GlobalFolderPath & "\" & "CoreConfig.ps1", 1, True)

to:

iRetCode = WshShell.Run ("C:\Windows\system32\WindowsPowerShell\v1.0\powershell.exe ""& '" & GlobalFolderPath & "\" & "CoreConfig.ps1'""", 1, True)

The file will then run from a directory with Spaces...